Categories
Internet, Unix en security

Error:509 in OpenOffice.org 3

Nu OpenOffice.org 3 langzaam gemeengoed begint te worden in verschillende distributies komen er ook issues naar boven. Zo ook met spreadsheets die goed in OpenOffice.org 2.4.1 nog goed werkte begonnen met de komst van versie 3.0 errors te vertonen.

De bekenste is misschien wel “Error:509” of “Fout:509” en staat voor “missing operator”, maar hoe dit te verhelpen is blijft meestal in het midden. Ook omdat het soms niet geheel duidelijk is waar deze fout zit. Zo ook met de onderstaande formule die correct werkt in oudere versies, maar sinds versie 3 stopt na werken.

=ALS(B20<>0;B20-B19;"");

Nu blijkt dat de semicolon aan het einde het probleem te zijn in dit voorbeeld.


=ALS(B20<>0;B20-B19;"")

Hopelijk blijft het bij deze ene keer, want bij elke grote update spreadsheets nalopen op fouten geeft geen vertrouwen. Het zal migraties van oa Microsoft Excel ook niet helpen en dit terwijl op het eerste gezicht OpenOffice.org 3.1 zeer zeker de upgrade waard is.

Categories
Life and society Open & free

OpenOffice.org 2.4

OpenOffice.org logoSteeds meer grote open souce projecten lijken de halfjaarlijkse release cycle te ontarmen en zo ook OpenOffice.org welke recentelijk zijn derde halfjaarlijkse release heeft gedaan met versie 2.4. En hoewel er voor de gebruiker op het eerst gezicht weinig verandering lijkt te zijn zit het hem ook voornamelijk in de details. Een paar van deze details zijn betere ondersteuning voor WebDAV, een verbeterde PDF export en tien nieuwe vertalingen van de applicatie waardoor meer gebruikers OpenOffice.org in hun eigen taal kunnen gebruiken.

Hier komt ook de kracht van open source naar voren en hoe het de wereld aan het veranderen is, maar ook al verandert is. Bedrijven zoals Sun Microsystems, Novell en IBM hebben dit ook gezien en passen hun bedrijfsmodel aan, maar sommige niet en Office Open XML er een voorbeeld van. Maar of OpenXML gaat helpen is de vraag, want steeds vaker komt het geluid van “waarom zou ik moeilijk doen met licenties en geld uitgeven als ik het ook kosteloos kan krijgen en bijna alle features die ik nodig heb.” De toekomst kan nog interessante worden nu de kracht van open en vrije software langzaam bij het grote publiek duidelijk wordt.