Categories
Internet, Unix en security

Error:509 in OpenOffice.org 3

Nu OpenOffice.org 3 langzaam gemeengoed begint te worden in verschillende distributies komen er ook issues naar boven. Zo ook met spreadsheets die goed in OpenOffice.org 2.4.1 nog goed werkte begonnen met de komst van versie 3.0 errors te vertonen.

De bekenste is misschien wel “Error:509” of “Fout:509” en staat voor “missing operator”, maar hoe dit te verhelpen is blijft meestal in het midden. Ook omdat het soms niet geheel duidelijk is waar deze fout zit. Zo ook met de onderstaande formule die correct werkt in oudere versies, maar sinds versie 3 stopt na werken.

=ALS(B20<>0;B20-B19;"");

Nu blijkt dat de semicolon aan het einde het probleem te zijn in dit voorbeeld.


=ALS(B20<>0;B20-B19;"")

Hopelijk blijft het bij deze ene keer, want bij elke grote update spreadsheets nalopen op fouten geeft geen vertrouwen. Het zal migraties van oa Microsoft Excel ook niet helpen en dit terwijl op het eerste gezicht OpenOffice.org 3.1 zeer zeker de upgrade waard is.